Leica Geosystems
Release Notes

Product: Leica Cyclone 3DR 2020.1.0
Date: 8 September 2020
From: HDS Software Product Management

Contents

What’s New ..................................................................................................................2
Scan to Plan ..................................................................................................................2
Analysis > Clash Analysis ............................................................................................9
Analysis > Measure .....................................................................................................11
Script > Favorite script “Inspection of Rail Catenary” .................................................12
Script > New functions in scripting ............................................................................13
File > Export > Support of gridded clouds ..................................................................14
Clean > Edit Polylines ..................................................................................................14
CloudWorx > Support of Setup IDs .............................................................................16
Surface Modeling > Convex Hull ................................................................................16
Surface Modeling > Subdivide Mesh ..........................................................................17
View > Edit Limit Box .................................................................................................18
Reverse Engineering > Support for new RDS arm .....................................................19
Reverse Engineering > Overlapped Surface ................................................................20
Generic > Editing grid .................................................................................................21
Generic > New toolbars ...............................................................................................21
Software Improvement Program ..................................................................................22
Free Viewer ..................................................................................................................23
Improvements ..............................................................................................................24
Bug Fixes ......................................................................................................................26
Leica Cyclone 3DR 2020.1 Compatibility .................................................................26
Recommended Computer Specifications ..................................................................26
Installation and Licensing Recommendations ........................................................26
Installation update Procedure ....................................................................................26
Licensing Setup ...........................................................................................................27
Licensing ......................................................................................................................31
Known Issues ...............................................................................................................32
Leica Cyclone 3DR supported file formats ...............................................................32
What's New

This is a major release, which includes the new Cyclone 3DR Free Viewer, the Software Improvement program, a new guided workflow mechanism and support for many new tools and workflows.

According to the maintenance expiration date policy, users under maintenance on August 1st, 2020 may access version 2020.1 with no new license required.

Scan to Plan

With this release, Cyclone 3DR now offers a guided workflow for 2D plan creation. This is the first of many guided workflows to follow which will support users in the creation of common deliverables.

Scan to Plan is perfect for applications requiring 2D plans from scan data particularly in the AEC and BIM industries. These plans may be either horizontal in the case of floorplans or cross-sections or vertical as in the case of façade elevations and vertical sections. Scan to Plan is most appropriate for applications consisting largely of straight-line segments and works on any point cloud data source.

Guided workflows combine existing tools within Cyclone 3DR into a simple to follow set of steps that walk users through the deliverable creation process. Guided workflows reduce the learning curve for working with Cyclone 3DR as a new user. By clustering and sequencing these steps, even new users can quickly create professional results thus reducing the time spent on a project and expanding the deliverables they can offer their clients. Users will also appreciate the addition of simple tools tips which further prompt the user.

Though creating 2D floorplans has always possible in Cyclone 3DR, different users had different workflows to achieve the same end and the tools were spread across different tabs. The Scan to Plan workflow codifies 2D floorplan creation and brings all the necessary tools into one location, so users are guided...
through the process of creating a floorplan. For example, the Scan to Plan workflow includes three key steps consisting of 8 unique tools:

To begin a new plan, select the point cloud, go to the Extract menu and launch the Scan to Plan command.

More than one point cloud can be selected when launching the command.

**Define Slices:** The Scan to Plan workflow is based on the automatic extraction of visible line segments. To support automatic extraction of these segments, the user must define slice(s) of the point cloud which include the features they wish to capture within their plan. You can define as many slices as you need and you may return to this step at any point to add additional slices if needed.

Slice definition is done through a simple wizard that allows you to define, preview and inspect your slices before advancing further in the workflow.
As you adjust the parameters of your slice, the viewing window will present a preview of your slice. Ensure that the lines are clean and dense to support automatic extraction.
Once all slices are defined, they can be viewed together to ensure that they offer complete coverage of the areas of interest.
Extract Plans: The purpose of the Extract Plans step is to extract and edit one group of planar polylines for each slice that was previously defined in the workflow. Polylines are planar since they are projected on the slice of interest.

You will work through each slice in turn. Users have two extraction modes to choose from.

- **Manual** mode: allows the user to click on parts of the slice to create new segments of the polyline. Click ENTER to validate the polyline and start a new segment. Segments can be extended to span sparse areas of the cloud and will be automatically joined. Click ESCAPE to exit the tool.
- **Automatic** mode: allows the user to batch extract polylines by selecting seed points. Polylines will be created based on the points visible within the slice along straight lines. Users will define a **Target resolution**. This value is the maximum distance between points that the polyline will attempt to span and should correlate to the thickness of the linework being extracted.

---

**Note:** At this time curved polylines cannot be extracted.
Review the polyline segments for either mode in the Outputs section. Once you have extracted all segments, click ENTER or ESCAPE to exit the automatic extraction mode. Users can inspect the automatic extraction and refine it to reduce the total number of polylines. The filtered cloud can un/displayed to assist the user in identifying areas which require attention. As the user finalizes polylines, they can be marked as final by clicking ENTER. The polyline will switch from yellow to green to indicate its status.

Polylines can be copied to other slices which share common geometry to reduce duplication of efforts.

Users can multi select polylines to save time for common actions. For example, the user can change the color, remove or to copy multiple polylines at a time.

As the linework algorithm extracts the very accurate position of the scanned data, many segments can be created inside extracted polylines. Users can use the Resample feature to reduce the overall segment and polyline count depending of the user’s desired output.

---

**Note:** Different tools for editing polylines are described in the Clean > Edit polylines section below.
Export plans: The third and final step of the workflow is exporting the extracted polylines for CAD and BIM applications. This step, which is optional, provides a few of user-friendly exporting tools:

- **DXF**: the user will define the save location. The DXF file will contain the 3D information from the extraction (normal direction and position of each group of polylines will be saved) and different layers (one layer for each slice).

- **Send to server**: a third party server such as AutoCAD must be launched, with an active drawing, to support this tool. The polyline objects will be populated into the current AutoCAD project, with the right 3D information and layer organization.

- **FloorPlanner**: this third option for exportation allows the user to integrate with the Floorplanner software. Users will create an FML file, that can include several floorplans (one floorplan per slice) and wall information extracted from polylines. As a final step, import the FML file in Floorplanner at the beginning of a new project.

As the user progresses through the Scan to Plan workflow, they may pause and return to a previous stage at any time as well as resume an in-progress Scan to Plan project without loss of progress to further refine results using the **Previous**, **Next** and **Exit** buttons at the bottom of the workflow pane, as shown below.

Simply click the “play” icon next to the Scan to Plan workflow in the tree to resume. Outputs can be made visible or hidden by clicking on the lightbulb icon.

*This workflow is available to users with the AEC and PRO licenses.*
Analysis > Clash Analysis

With the 2020.1 release, Cyclone 3DR adds a new Clash Analysis feature which provides a simple means of comparing a BIM project to the as-built point cloud in order to check and to analyze clashes that are detected between the CAD and BIM objects and the measured point cloud. This workflow is optimal for test fitting new object’s for retrofit or equipment replacement applications.

When using this workflow, we recommend focusing on specific objects to analyze and to isolate them rather than running an analysis on a many hundred or many thousand object model, in order to generate a manageable number of clashes.

Launch the command in the Analysis menu and adjust your settings to the project specifications. There are three key settings the user can control:

- **Tolerance**: BIM/CAD objects and the point cloud will be marked as a clash when they are closer than the user-defined tolerance.
- **Cluster distance**: adjust the cluster distance to separate group of points. Each group of points will be considered independently when analyzing clashes. Setting the cluster distance too high may result in additional, false positive clashes which may only correspond to a single clash.
- **Filter clashes**: this setting allows users to ignore false clashes that may be caused by noise in the data rather than a genuine collection of points. This setting is optional and can be adjusted after the calculation.

Users can preview the results and begin to QA each one from the Results section. Clashes will be organized according to what BIM/CAD object they intersect with. One object may have many clashes. All detected clashes will be classified as “unknown” until they are either marked as “Clash” or “No Clash” by marking the check box appropriately. The clashes will be displayed as either green, orange or red depending on their status to support simple visual progress checks.

As the user navigates through the list, they will be presented with two views. The detail view will zoom to the location of the clash, allowing for close inspection while the global view will show the clash in context of the larger object and the point cloud.

A report will be automatically generated from the clash analysis which can be customized in the report editor.
Clash Settings should be defined for the analysis and may be changed.

Results are displayed tabularly and visually with simple color coding for their inspection status.

Optional filtering accounts for data noise.

When activated, users' selection the table will direct their view in the viewing window.

Workflow controls

Tool tips guide the user.
• Shortcuts are provided for the management of clashes in the list.

![Shortcut Information]

This feature is available to users with the AEC and PRO licenses.

**Analysis > Measure**

Cyclone 3DR 2020.1 provides two new items for measurement.

• **Quick distance Measurement**
  Distances along the active coordinate system axes are displayed for a better user understanding of the context. The unit and the precision depend on the configured settings.

![Quick Distances Measurement]

The new quick distance measurement tool can be accessed in the toolbar.

• **Point Measurement / Distance between planes measurement**
  An option has been added to store the current coordinate system name in the label comment.
  To access this new option, go to the Analysis menu, Measurement command and select the appropriate method. The choice of current coordinate systems option can be un/checked.
These features are available to users with the Standard license.

**Script > Favorite script “Inspection of Rail Catenary”**

In the 2020.1 version, a new favorite script is provided in the Script menu which extends the program’s support for automated rail workflows. **Inspection of Rail Catenary** is now provided as a favorite script to analyze data, usually scanned from mobile mapping solutions, and to extract information from the catenary. The script delivers catenary deviations along the line for simple analysis.

To launch the favorite script, the project must include the following polylines. These should be extracted prior to running the script as they are selected when the script is executed.

- The catenary line
- The left and right rails
- The axis

Complete instructions are detailed directly in the script code. Sample data is also provided on the GitHub library [https://github.com/Cyclone3DR/Scripts/tree/master/CatenaryInspection](https://github.com/Cyclone3DR/Scripts/tree/master/CatenaryInspection).

The script will return:

- A CSV file that contains catenary deviations at each inspected point.
- Horizontal and vertical inspection objects in Cyclone 3DR (inspected polylines).
This feature is available to users with the Standard license.

Script > New functions in scripting

Three new groups of Scripting functions are available in Cyclone 3DR 2020.1 release to support more complex, custom scripts which leverage the breadth of tools available in Cyclone 3DR.

- Conversion of UCS into SMatrix
  - FromUCS
  - FromActiveCS
  - UpdateUCS

- Methods to manage self-intersections on SMultiline objects
  - GetAutoIntersections
  - RepairAutoIntersections
  - SuppressSmallLines

- Methods to manage local number conversion
  - GetThousandSeparator
  - GetLocalSeparator
  - ConvertStringToNumber

The Help page for scripting in Cyclone 3DR has been updated to explain how these new functions can be used.

This feature is available to users with the Standard license.
**File > Export > Support of gridded clouds**

With the 2020.1 release, it is possible to preserve the grid information from the original E57 files for use within Cyclone 3DR and for later publishing rather than simply importing them.

In order to keep the grid information during an export job, the user must select the appropriate file format and check the option to save the grid information from within **File > Export**. Whether a cloud had gridded information is visible in the properties. Only data which is imported as gridded can be published as such.

This feature allows users who work with gridded E57 point clouds to benefit from any Cyclone 3DR features for point cloud (cleaning and inspection) which utilize gridded information.

![Properties](image)

This feature is available to users with the Standard license.

**Clean > Edit Polygons**

Polyline management has been improved with support for editing polylines once created. This command allows users to manually edit polylines after auto-extraction or manual drawing. Many workflows, that require or generate polylines (newly released Scan to Plan for example) will benefit from this improvement. Editing polylines allows users to efficiently correct errors without redoing work, making auto-extraction with manual QA an effective workflow inside of Cyclone 3DR.

Simply select the polyline you wish to edit and go to the **CLEAN** menu and launch **EDIT POLYLINE** command.
users can select the red handles which indicate the extremities of segments and either delete them or drag them into the correct position.

When selected, additional options are available to the user to edit the polyline:
- Click on the “↔” Icon to extend or shorten the polyline along the current direction.
- Click on the “+” Icon to add a new segment and a new red handle.
- Click on the “T” Icon to extend the polyline and create a new segment along the perpendicular direction of the current segment.

Blue handles in the middle of a segment are used to add segment in the middle of the polyline. These midpoint handles can be converted to and endpoint by selecting the arrow icon that appears upon hover.
Note that the command will automatically project the position of the new/shifted point along the current plane of the polyline. Therefore, this new command is specifically recommended for 2D polylines.

*This feature is available to users with the Standard license.*

**CloudWorx > Support of Setup IDs**

Thanks to recent EpcA improvement, Cyclone 3DR now supports Setup IDs of point cloud that are converted in the software from CloudWorx Menu, which means that the following features are provided after conversion of the point cloud:

- The shortcut SHIFT+S allows the user to display the scan position.
- Double-click on a scan position allow the user to navigate to the scan view.
- It is possible to explode the cloud according to scan position.
- Cyclone 3DR can understand the “sign” (positive or negative) of each point of a cloud, towards the position of the corresponding scan.

recognizing the Setup ID benefits inspection and meshing applications:

- A comparison/inspection between 2 clouds can identify the difference between a hole and a bump for a better analysis.
- 3D meshes that result from such point cloud which contain lots of 3D details are now more accurate.

---

*CloudWorx point clouds that support Setup IDs are LGS point clouds published from Cyclone Register 360 2020.0.0 or later.*

---

**Surface Modeling > Convex Hull**

With the release of Cyclone 3DR 2020.1, users now have a new surface modeling command—convex hull surface from a point cloud. This command extrapolates from the angles of a mesh and is perfect for checking clearance and fit of objects into existing conditions.

Simply select the input point cloud and go to the SURFACE MODELING menu and launch the CONVEX HULL command. The mesh of the convex hull is automatically created and displayed.
This feature is available to users with the Standard license.

**Surface Modeling > Subdivide Mesh**

Meshing in Cyclone 3DR has been improved thanks to the new command Subdivide Mesh. This new tool allows users to benefit from an additional way to refine and to model a mesh. Mesh subdivision makes the mesh more uniform and more accurate, allowing users to target changes only to specific areas. It is useful for any modeling application that requires meshing in Cyclone 3DR.

Simply select the mesh and go to the Surface Modeling menu and launch Subdivide Mesh. Define the maximum length of the triangle edges of the final mesh: for example if the user chooses 50mm, any triangle edges will be maximum 50mm long, which means that every triangles of the mesh whose edge length is higher than 50mm, will be subdivided to fit the user parameter.

Users may wish to change the representation of the mesh into Smooth+Wire. This step is optional but useful to analyze the result from the command.
View of the results from Subdivide Mesh

Top view is before subdividing – Bottom is after a subdivision with a 1-meter maximum length for triangle edges

This feature is available to users with the Standard license.

View > Edit Limit Box

With the release of Cyclone 3DR 2020.1, users can now perform simple edits to an existing limit box to support rapid clipping and visualization.

- **Pressing CTRL + left mouse button** allows the users to drag and drop the whole limit box while maintaining its main axis directions and its size. Only the global position of the limit box is translated.
- **Pressing CTRL + SHIFT + Left mouse button** allows the users to drag and drop two opposite faces (front+back OR top+bottom OR left+right) and to move them along the appropriate main direction of the limit box. The size and main directions of the limit box remain unchanged in this case, this shortcut allows to edit the size of the limit box along one constrained direction.

While a limit box is active, instructions are displayed in the bottom left corner of the scene to guide the user in the use of these new shortcuts.

![Instructions](image)

*This feature is available to users with the Standard license.*

**Reverse Engineering > Support for new RDS arm**

The ROMER RS-Square data (RDS 5.4) is supported with Cyclone 3DR 2020.1 release, which will be beneficial for Manufacturing applications that need arm usages.

After connecting Cyclone 3DR with the arm, go to the REVERSE ENGINEERING menu and utilize the features from the SCAN group of commands, that were released with 2020.0 version.
This feature is available to users with the AEC and PRO licenses.

Reverse Engineering > Overlapped Surface

A secondary axis can be defined to adjust the surface.

When defining an overlapped surface, it is often necessary to manually adjust the surface that will be optimized onto the mesh. The initial surface orientation can now be adjusted so that its orientation is completely controlled by the user.

Previously, only the normal axis of the overlapped surface could be defined by the user. Thanks to the new release, defining a main axis is available for a more appropriate result for any CAD engineering application.

Top left: adjusting the 2 directions of the input surface. Top right: the surface once optimized onto the mesh. Bottom: the surface has been restricted and overlapped onto the mesh for visual purpose.
This feature is available to users with the AEC and PRO licenses.

**Generic > Editing grid**

Grids can now be edited throughout the program in the tree view, context menu and ribbon to support simple modification for custom scales. Main steps and subdivisions in local \( (U,V) \) coordinate system can be customized.

From within the tree, click on the circle to manage the representation of objects. A small dialog will appear for quick editing. Alternatively, you can double click or **right click** | **Edit** to access the grid editing dialog.

This option can also be access from the **View Menu | Edit Grid**

![Image of grid editing](image1.png)

This feature is available to users with the Standard license.

**Generic > New toolbars**

With this release, Cyclone 3DR introduces new user-friendly, contextual toolbars to replace the clustering of tools within the menu ribbon. This change ensures that the relevant tools are always accessible to the user based on their selection and supports the new guided workflows introduced above.

![Image of new toolbars](image2.png)
Upon selecting a tool from the toolbar, the user may be able to activate advanced options or settings for that tool based on their selection (e.g. target type and diameter selection within the target picking tool).

This feature is available to users with the Standard license.

**Software Improvement Program**

Cyclone 3DR 2020.1 introduces the Software Improvement Program (SIP). The purpose of the SIP process is to improve Cyclone 3DR through anonymized user metrics. This data-driven development will better account for the needs of all users. The program is completely anonymous and optional. Users may opt out at any time.

With the 2020.1 release, Cyclone 3DR will begin to collect completely anonymous usage information that will contribute to the design of new features, future workflows and relevant improvements of the product.

The SIP is totally anonymous. No personal data is collected in any form; users will never be contacted regarding their usage. SIP information will be available only to the Hexagon Product Management and development teams in aggregate for the purposes of designing new features and improvements.

In addition to being totally anonymous, participation in the SIP is optional.

A dedicated FAQ has been created to explain the Software Improvement Program in more detail.

Please refer to Settings > Software Improvement Program to read the FAQ and change your participation status.
SIP participation is not license controlled.

**Free Viewer**

Cyclone 3DR free viewer is now enabled and can be downloaded from the Leica Geosystems corporate website.

The free viewer is designed to supplement user’s full Cyclone 3DR license experience and offer a means for unlicensed users to take advantage of the viewing tools of Cyclone 3DR.

The viewer will run for 7 days without a license. You can request a permanent license from within the viewer. It provides basic tools for viewing, clipping, measurements and label and gradient editing.
Improvements

In 2020.1.0 release:

1. **Home > Settings:** Temporary folder can now be customized. Allowing users to select a location that best suits their workflow and computer specifications.

2. **Home > Copy/Paste:** User Coordinate Systems can be copied and pasted.

3. **File > Import / Export MSD format:** Add support for MSD file format. MSD now replaces PBI as the proprietary file format for storing mesh data.

4. **File > Import IGES/STEP:** Users can now sew surfaces.

5. **File > Import / Export DXF format & File > Import / Export DWG format:** The structure of original CAD remains after import. CAD layers are maintained after import. Type of objects are now read in Cyclone 3DR, such as polylines and texts. This improvement increases the interoperability between Cyclone 3DR and CAD software.

6. **File > Import PLY format:** PLY format files that contain points only can now be imported as a point cloud.

7. **CAD Object:** Added compatibility with direction tool to quickly extract the local normal.
8. **CAD Object**: Extraction of center/middle points of Circular/Cylindrical/Spherical CAD objects is now enabled.

   ![Image of the toolbar for selection](image)

   Zoom on the toolbar for the mode of selection

9. **Surface Modeling > Reduce**: The maximum length of triangle edges of a mesh can be now controlled as an option in the command **Reduce**. This allows to create meshes with triangles that are not too big.

10. **Clean > Distance**: UI has been updated to improve distance field readability.

11. **Extract > Extract Cloud**: When a cloud is extracted from a mesh, the normal vectors of the triangles can be maintained on the points of the output cloud.

12. **Coordinates > Input point widget**: It is now possible to copy/paste all coordinates of a point in another point widget in the application or in a text editor.

   ![Screenshot of the point coordinates widget](image)

   Screenshot of the point coordinates widget that is available in many Cyclone 3DR commands. Shortcuts CTRL+C / CTRL+V work as well to copy/paste coordinates X Y Z.

13. **Report Editor**: Previews of PDF reports were improved in order to make to them similar to extracted PDF documents.

14. **Extract > Sections**: Quotations can now be extracted from Surface Analysis and Color Direction gradient.
Bug Fixes

In 2020.1.0 release:

1. **File > Import IGES**: Fix import of cylinder.
2. **File > Export OBJ**: Fix a bad junction issue that used to occur between 2 external borders of spherical images in from OBJ files textured and exported from Cyclone 3DR.
3. **Home > Copy/Paste**: Fix crash that may occur while pasting point clouds to another instance.
4. **Rectangular selection**: Fix the situation of a mesh that is selected even if selection rectangle was not crossing the object in the scene.
5. **Analysis > Stockpile**: Some stocks can be removed when editing a project with more than 10 stockpiles.
6. **Texturing > Texture Atlas**: Some images could disappear from the texture in some conditions.
7. **Texturing > Extract Ortholmage**: Fix accuracy issue in exported parameters (pixel size, image width and height).

**Leica Cyclone 3DR 2020.1 Compatibility**

- Cyclone 3DR is compatible with CLM 1.8 and higher.
- Cyclone 3DR is compatible with JetStream Enterprise 1.3 and higher.
- Cyclone 3DR is compatible with LGS files.
- Cyclone 3DR is compatible with Cyclone IMP databases from Cyclone 6.0 or higher, however improved rendering will only be seen with IMPs from Cyclone 9.3 or higher.

**Recommended Computer Specifications**

- CPU: 2 GHz Dual Quad Core i7 or higher (i5 minimum)
- RAM: minimum 16 GB or more for 64-bit OS
- Graphic Card: NVidia Quadro or GeForce 1 GB (with OpenGL support, versions 4.3 or higher)
- Operating system: Microsoft Windows 7, 8, 10 (64 bits supported)
- Hard Disk: 3 GB free disk space

**Installation and Licensing Recommendations**

**Installation update Procedure**

1. Follow the directions in the Setup Wizard
2. Select the option to update Cyclone 3DR (or repair if you want to change installing options)

3. Complete the installation by selecting “Finish”.

Licensing Setup
1. Once you have installed Cyclone 3DR, open the Client License Manager for Floating Licenses. The program is located here: Start Menu | All Programs | Leica Geosystems | Client License Manager
2. Choose the "Activate new licenses" option.

3. Enter your Entitlement ID (EID) in the field. To enter multiple EIDs separate them with a semicolon ";" and no space.
4. After you have entered your EID, choose the "Check for Activatable licenses" button in the bottom right of the page.

![Image of software interface showing Add license button]

5. Once your licenses are activated you can launch Cyclone 3DR.
6. Go to Settings and select License.

![Image of software interface showing License options]

7. If you have entered the EID inside your local CLM, select **Localhost**. If the license is on a dedicated server, enter the server name in **Server Address**.
8. You can select the features you want to check out from CLM. The available options to checkout will correspond to the options you purchased which are contained in your EID.
9. Once the options are selected, click on **Activate license**.

10. When a new version is available, click **Check for Uploaded**. A dialog will appear which links you to the Leica Geosystems website in order to download the new version:

**Licensing**

All users with valid CCP or CCP which was valid as of 1 September 2020 for Cyclone 3DR, can run this new version of Cyclone 3DR.

All users with valid CCP or CCP which was valid as of 1 September 2020 for 3DReshaper, can run this new version of Cyclone 3DR with no new license required.
Users with 3DReshaper licenses with expired CCP must migrate to Cyclone 3DR in order to continue to access updates and support. Please contact your sales or support personnel for more information.

**Known Issues**

For the initial release of Cyclone 3DR, certain 3DReshaper features are not yet enabled. These features will be added to Cyclone 3DR in future releases. Cyclone 3DR will reach core feature parity with 3DReshaper. The following differences exist:

- The Documentation Center is only available in English.
- Some CAD import and export issues might happen. For example, when exporting a cloud in DXF, some entities might be missing. To avoid this, it is preferable to use the Send to AutoCAD option.
- If DXF can be imported with a standard version, DWG requires the AEC or PRO Edition. One workaround is to use the 3DSend command from AutoCAD to Cyclone 3DR.
- .RSH files are natively compatible with Cyclone 3DR, and the last version of 3DReshaper is compatible with .3DR files (with a limit on textures and CAD objects).

**Leica Cyclone 3DR supported file formats**

Please reference the Cyclone 3DR Technical Specification for a complete list of supported file types per license.

<table>
<thead>
<tr>
<th>Import</th>
<th>Export</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Point Cloud</strong></td>
<td>ASCII FILES (*.asc, *.csv...)</td>
</tr>
<tr>
<td>Files ASCII (*.asc, *.csv, *xyz, *.yxz...)</td>
<td>Binary files (*.nsd)</td>
</tr>
<tr>
<td>Leica Geosystems (*.pts, <em>.ptx) and LGS (</em>.lgs)</td>
<td>Leica Geosystems (*.pts, *.ptx)</td>
</tr>
<tr>
<td>Leica Nova MS50/60 (*.sdb, *.xml)</td>
<td>E57 (*.e57)</td>
</tr>
<tr>
<td>ShapeGrabber (*.3pi)</td>
<td>IGES (*.igs)</td>
</tr>
<tr>
<td>3DReshaper binary file (*.nsd)</td>
<td>LAS (*.las)</td>
</tr>
<tr>
<td>Autodesk DXF (*.dxf)</td>
<td>LAZ (*.laz)</td>
</tr>
<tr>
<td>STL (*.stl)</td>
<td>Autodesk DXF (*.dxf)</td>
</tr>
<tr>
<td>Polyworks (*.psl)</td>
<td></td>
</tr>
<tr>
<td>Leica T-Scan + Steinbichler (*.ac)</td>
<td></td>
</tr>
<tr>
<td>LIDAR data (*.las; laz)</td>
<td></td>
</tr>
<tr>
<td>Other ASCII (*)</td>
<td></td>
</tr>
<tr>
<td>Zoller and Fröhlich *(.zfs - *.zfc)</td>
<td></td>
</tr>
<tr>
<td>PLY points without triangles (*.ply)</td>
<td></td>
</tr>
<tr>
<td>ESRI ASCII (raster format *.asc)</td>
<td></td>
</tr>
<tr>
<td>FARO (*.fls - *.fws)</td>
<td></td>
</tr>
<tr>
<td>POLYWORKS (*.psl)</td>
<td></td>
</tr>
<tr>
<td>E57 (*.E57 files)</td>
<td></td>
</tr>
<tr>
<td>LandXML files (*.xml)</td>
<td></td>
</tr>
<tr>
<td>DOT Products (*.dpl)</td>
<td></td>
</tr>
<tr>
<td>RDBX</td>
<td></td>
</tr>
<tr>
<td>Mesh</td>
<td>STL format (*.stl)</td>
</tr>
<tr>
<td>------</td>
<td>------------------</td>
</tr>
<tr>
<td></td>
<td>Binary PBI format (*.pbi)</td>
</tr>
<tr>
<td></td>
<td>DXF 3Dface format (*.dxf)</td>
</tr>
<tr>
<td></td>
<td>Ascii POLY format (*.poly)</td>
</tr>
<tr>
<td></td>
<td>OBJ format (*.obj)</td>
</tr>
<tr>
<td></td>
<td>Ascii Leica format (*.msh)</td>
</tr>
<tr>
<td></td>
<td>VRML files (*.wrl / *.vrm / *.iv)</td>
</tr>
<tr>
<td></td>
<td>OFF files (*.off)</td>
</tr>
<tr>
<td></td>
<td>PLY (*.ply)</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Contour / Section</th>
<th>IGES format</th>
<th>IGES format</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>DXF polyline format</td>
<td>DXF polyline format</td>
</tr>
<tr>
<td></td>
<td>Binary MLI format (*.mli)</td>
<td>Binary MLI format (*.mli)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CAD Model</th>
<th>IGES</th>
<th>IGES</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>STEP</td>
<td>STEP</td>
</tr>
<tr>
<td></td>
<td>DWG</td>
<td>DXF</td>
</tr>
<tr>
<td></td>
<td>IFC</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RVT</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Project</th>
<th>Cyclone 3DR (*.3dr)</th>
<th>Cyclone 3DR (*.3dr)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>DXF - DWG</td>
<td>DXF</td>
</tr>
<tr>
<td></td>
<td>XML</td>
<td>PDF 3D</td>
</tr>
<tr>
<td></td>
<td>Cyclone ModelSpace View (from IMP)</td>
<td>SKETCHFAB</td>
</tr>
<tr>
<td></td>
<td>JetStream Enterprise project</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Image</th>
<th>BMP</th>
<th>Ortho-image including georeferencing information as TXT file</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>JPEG</td>
<td>JPG</td>
</tr>
<tr>
<td></td>
<td>JPG</td>
<td>JPEG</td>
</tr>
<tr>
<td></td>
<td>PNG</td>
<td>BMP</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PNG</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TIF</td>
</tr>
<tr>
<td></td>
<td></td>
<td>GIF</td>
</tr>
</tbody>
</table>